Errore “php_admin_value” dopo l’aggiornamento di virtualmin

Aggiornando Virtualmin si può riscontrare all’avvio di apachel’errore “apachectl[9044]: Invalid command ‘php_admin_value’, perhaps misspelled or defined by a module not included in the server configuration” .

Il problema è che le versioni più recenti di Virtualmin non abilitano mod_php per impostazione predefinita, ma ripristrinando il backup dell’installazione precedente nel file di configurazione ci potrebbero essere quelle righe nella configurazione di Apache.  La soluzione migliore è rimuovere queste righe.

Per elimanare le righe dove vi è definita il valore php_admin_value con un solo comando, basta digitare il seguente comando:

sed -i -e ‘/php_admin_value/d’ *.conf

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *