apt-get update gpg error – debian wheezy – Vodafone Station

Quando effettuavo apt-get update, avevo il seguente errore:

root@Debian:~# apt-get update
Get:1 http://security.debian.org wheezy/updates Release.gpg [2255 B]
Get:2 http://ftp.it.debian.org wheezy Release.gpg [2256 B]
Get:3 http://security.debian.org wheezy/updates Release [2255 B]
Err http://security.debian.org wheezy/updates Release

Get:4 http://ftp.it.debian.org wheezy-updates Release.gpg [2256 B]
Get:5 http://ftp.it.debian.org wheezy Release [2256 B]
Ign http://ftp.it.debian.org wheezy Release
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://security.debian.org wheezy/updates Release: The following signatures were invalid: NODATA 1 NODATA 2

E: GPG error: http://ftp.it.debian.org wheezy Release: The following signatures were invalid: NODATA 1 NODATA 2

 

Il contenuto di /etc/apt/source.list

 

deb http://ftp.it.debian.org/debian/ wheezy main
deb-src http://ftp.it.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as ‘volatile’
deb http://ftp.it.debian.org/debian/ wheezy-updates main
deb-src http://ftp.it.debian.org/debian/ wheezy-updates main

 

La problematica apt-get update gpg error  nel mio caso era causato dalla Vodafone Station. Sicuramente applicano dei filtri e causano questo errore. Nei forum troverete indicazioni a fare la provo a cambiare il file /etc/apt/source.list ma il problema se avete vodafone non lo risolverete.